2

Internet Explorer support (for clients)

Hi all,

I don't mind the forced browser support (Chrome, Safari, Firefox) for myself, but some clients are getting the same message when they try to login to their client area.  For example, when I sent them an invoice today, they got pretty frustrated at being forced to switch from IE (latest version 9).  Since I don't like to frustrate my clients, especially when they're trying to give me money(!), I'm wondering what are the plans are for supporting IE, especially now that Pictage has taken over.

Thanks,

Doug

0 comments

Please sign in to leave a comment.